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Representations in this User Guide are meant as an overview and quick reference.  Full details 
can be found in the On-Line manuals located at the ADIVA Corporation website - www.adiva.com

All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, 
or transmitted, in any form or by any means - electronic, mechanical, photocopying, recording, 

or otherwise - without the prior written permission of ADIVA Corporation.

ADIVA Corporation provides this User Guide "as is", without warranty of any kind, either expressed 
or implied, including, but not limited to, the implied warranties of merchantability and fitness for a 

particular purpose. ADIVA Corporation may make improvements and/or changes in the product (s) 
and/or the program (s) described in this manual at any time and without notice. 

Although ADIVA Corporation has gone to great effort to verify the integrity of the information herein, 
this publication could contain technical inaccuracies or typographical errors. Changes are periodically 
made to the information herein. These changes will be incorporated in new editions of this publication.

Notice

http://www.adiva.com/


  

AdivaView Graphical User Interface 
Highlights

• Layer display checkbox also makes the layer active for item selection (different from AdivaTools 
DRC).

• Layer Display and Action Display are both dockable panels.  They can be moved to different 
locations to create a larger viewing area for a design.

• All data created automatically by Adiva is stored in the local directory for a particular job.
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Starting the AdivaView Interface
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On the Windows Desktop, double-click the AdivaView icon
On the command line, type   >AdivaView -V <jobname>   (jobname is optional)

The graphical Interface will appear and if a jobname is supplied it will appear like below. 

If a job name is not supplied, the Layer Listing on the right will be empty and the next step 
will be to access the File menu to find and load a job.



  

Menus
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Across the top of the AdivaView Graphical Interface are a series of menus.  
Several of the menu items are inactive for AdivaView therefore not listed in this guide

The File Menu performs the following….

Select and Load an existing database

Exit and close AdivaView

Removes an added database used for either revision compare
or design review (ex: Rev A or Rev B, etc…).
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The View Menu controls various graphical related functions.
Take close note of the keyboard shortcuts that are also available for each function

Keyboard Shortcuts

These functions control display of toolbars and activity displays

Produces a file that can be used by certain CAD systems to
center their screen to the Adiva screen

See the Item Select Function described later in this User Guide
Essentially this function allows a user to select or un–select
an item(s) on the screen

Center and fit all graphics on the screen

Refreshes the current graphics screen
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The View Menu controls various graphical related functions.
Take close note of the keyboard shortcuts that are also available for each function

Keyboard Shortcuts

Zoom Functions:

   Zoom allows a user to draw an area to zoom
   click left-mouse down-drag-let go - defined area zooms in

   Zoom-In allows a user to zoom in 1 level on the current screen
      Mouse Scroll-Up performs the same function

   Zoom-Out allows the user to zoom out 1 level on the current 
screen
      Mouse Scroll-Down performs the same function

   Center Zoom-In allows the user to zoom in 1 level centering on the
   mouse location

   Center Zoom-Max allows the user to zoom in 8 levels centering on
   the mouse location

Back returns the user to the previous displayed screen
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The View Menu controls various graphical related functions.
Take close note of the keyboard shortcuts that are also available for each function

Keyboard Shortcuts

Pan Functions:

   Pan allows a user to click left-mouse down on a location and drag 
   a line to a new location (let go) then redraws the screen with the 
   original location now in the new location.  

      In short: drag this point from here to here

  Mouse scroll click-down-drag-release performs same function 
      without placing user in “Pan-State”

   Pan Up moves the current window-of-view 90% up

   Pan Down moves the current window-of-view 90% down

   Pan Left moves the current window-of-view 90% to the left

   Pan Right moves the current window-of-view 90% to the right

Back returns the user to the previous displayed screen
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The Add Menu performs the following….

Select Add – Database to load a second or more
databases on top of an already loaded database.

This is useful for revision review between two or
more versions of the same design.

When selected, a Windows navigation dialog will
appear allowing the selection of a second (or more)
databases to be loaded for review.

See the AdivaView Function User Guide for 
application details.
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The Special Menu performs the following….

Measure provides a tool allowing the user to drag a line
anywhere on the screen and a total distance from start
to end is displayed in the status bar at the bottom of the
Adiva Graphical Interface.

Select Measure > Left-Mouse down-drag-let go
on the graphics screen

“Snap” option on the Selection Tab is helpful with 
this function

Layer Description displays the layer stackup as defined for
this design.  Select this and a dialog will appear showing
a description of each layer and its Z-Position (distance from top)
of each layer.
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The Toolkit Menu performs the following….

Archive generates a series
of web based images that 
communicate graphical images
of questionable or notable 
material.
 
See the AdivaView Function 
User Guide for application 
details.

Layer Compare performs a function comparing any two layers of a design.  This is a graphical
Comparison allowing the user to “seek” to any differences between the two layers.

Multiple layers can be batched at one time for a complete design comparison.  For instance,
revision A of a design can be compared back to the original design determining any and all
differences between the revisions. See the AdivaView Function User Guide for application 
details.

Net Length Report creates a comma delimited file listing net length
databy net name.  This file can be loaded into a common spread 
sheet program for review.



  

ToolBar
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The ToolBar provides easy access to many functions
that are duplicated by a menu selection or keyboard shortcut

File Open – select and load an existing database

Select Item – allows user to select or un-select items on the screen
   See the Item Select Function described at the end of this User Guide.

Find Function brings the Find Tab forward in
the action tabs to provide searching for
XY locations Measure provides a tool allowing the user to drag a line

anywhere on the screen and a total distance from start
to end is displayed in the status bar at the bottom of the
Adiva Graphical Interface.

Select Measure > Left-Mouse down-drag-let go
on the graphics screen

“Snap” option on the Selection Tab is helpful with 
this function

CadLink produces a file that can be used by certain CAD 
systems to center the CAD screen to the Adiva screen
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The ToolBar provides easy access to many functions
that are duplicated by a menu selection or keyboard shortcut

Layer Compare - performs a function comparing any two layers of a design.  This is a graphical
comparison allowing the user to “seek” to any differences between the two layers.

Multiple layers can be batched at one time for a complete design comparison.  For instance,
revision A of a design can be compared back to the original design determining any and all
differences between the revisions.

See the AdivaView Function User Guide for application details.

Flip – turns the design over for easy viewing from the backside.
Selecting Flip again flips the design back over.

The message bar at the bottom of the screen reports the current
state of viewing for the design – Normal - Flipped 
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The ToolBar provides easy access to many functions
that are duplicated by a menu selection or keyboard shortcut

Archive generates a series of web based
images that communicate DRC check
violations.
 
See the AdivaView Function User Guide
for application details.

Refreshes the current graphics screen

Closes and opens the Action Tab on the left side of
Adiva’s Graphical Interface.  Closing this tab allows
greater viewing area for a design.

Closes and opens the Layer Display Tab on the right side of
Adiva’s Graphical Interface.  Closing this tab allows
greater viewing area for a design.
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The ToolBar provides easy access to many functions
that are duplicated by a menu selection or keyboard shortcut

Refreshes the current graphics screen

Center and Fit all graphics on the screen

Zoom allows a user to draw an area to zoom
   click left-mouse down-drag-let go -- defined area zooms in

Zoom-In allows a user to zoom in 1 level on the current screen
Mouse Scroll-Up performs the same function

Zoom-Out allows the user to zoom out 1 level on the current screen
Mouse Scroll-Down performs the same function

Back returns the user to the previous displayed screen
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The ToolBar provides easy access to many functions
that are duplicated by a menu selection or keyboard shortcut

Refreshes the current graphics screen

Pan allows a user to click left-mouse down on a location and drag a line to a new location (let 
go) then redraws the screen with the original location now in the new location.  Mouse scroll 
click-down-drag-release performs same function without placing user in “Pan-State”.

In short: drag this point from “here” to “there”

Pan Up moves the current window-of-view 90% up

Pan Down moves the current window-of-view 90% down

Pan Left moves the current window-of-view 90% to the left

Pan Right moves the current window-of-view 90% to the right



  

Layer Display
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Layer Display List controls access to visual and physical selections
of each graphical layer of a design

This is the “Show” column.  Check this box
to “Show” all layers on the screen.  Uncheck
this box to turn off display for all layers.
(Screen refresh may be required to see selected layers)

Check individual boxes to show individual layers
(Screen refresh may be required to see
selected layers)

If a box is checked on for show, this layer also
becomes “active” meaning items can be selected
on that layer.

Checking a box in the 2nd column shows that layer
on top of all other layers set to display
(only one layer at a time can be on TOP)
(screen refresh is automatic)
(TIP!  It is sometimes handy to use this to redraw
the screen when layer selections are changed)

Checking a box in the 3rd column inverts the
graphical image – useful in showing negative
layers in their “real” view
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Layer Display List controls access to visual and physical selections
of each graphical layer of a design

Click on the color box to change a layer color

Select a new color and choose OK to update
layer color (screen refresh may be required)



  

Action Display Tabs
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Selection Tab controls the function and reports the results of a “select” action

Selected Item information:

   Type of item selected - flashed pad, segment, polygon, arc
   Quantity of items selected
   Net name from CAD system
      - number in parenthesis is Adiva net number
   Reference Designator & Pin Number
   Aperture size of object selected, its rotation and number
   Class of a pad/hole item
      -  = pad/hole class not available
      S = Surface Mount
      P = pin-thru hole
      V = via
      T = tooling hole
      t = test point
      F = fiducial
      C = cosmetic (no real function)
   Layer item is located on
   Separation spacing between any two items selected
   XY coordinates of a selected item

See the Item Selection slides at the end of this guide for “How to Select” information….

Snap option controls the select and measure routines…
snap to pad, snap to line, snap to item, etc…

Separation option controls the report of any two items selected…
    Edge - reports the spacing edge-to-edge between two selected items
    Center - reports the spacing center-to-center between two selected items
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Find Tab provides search functions

Type in an XY location either in inches or mm,
select Search and a crosshair will appear at 
the requested location of the design.
  
                                                          Selecting Clear removes the crosshair from display.
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Nets Tab Locates and Highlights Selected Nets in Graphics

Select a net in the Net Highlight box and the net
is centered and Highlighted in white at current
zoom level in the Graphics screen

Select another net and the first is un-highlighted
and the next selection is highlighted

Drag and Drop
nets for detailed
selection info

Enter a net name (wildcards work *) and 
select “Add” and net name(s) drop into
Selected Nets list

Nets in Selected Nets box are highlighted in
layer color to view routing topology

Actual Net Length is also displayed
(extra traces under pads are not part of length
calculation – reports TRUE net length)

Click on Net Name and component outlines
appear – click again and outlines disappear

Click on RefDes-pin# and a crosshair appears
at component pin location – click again and the
crosshair disappears

Drag a net name 
outside the box to
remove a net from the 
Selected Nets list 
         - or -
Drag “Database” to
remove all nets

Design Net Names 
listed in Net Highlight 
box
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Components Tab Locates and Highlights Selected Components in Graphics

Drag and Drop
components for 
detailed selection info

Drag a component 
outside the box to
remove it from the 
Selected Comps list 
         - or -
Drag “Database” to
remove all components

Select a component in the Component Highlight
box and the component is centered and 
highlighted in white at current zoom level in 
the Graphics screen

Select another component and the first is 
un-highlighted and the next selection is 
highlighted

Enter a component name (wildcards work *)
and select “Add” and the component(s) drop
into the Selected Components list

Text entry selection is filtered by Top or 
Bottom Components check boxes

Components in Selected Components box 
are highlighted in white

Click on RefDes-pin# and a crosshair appears
at component pin location – click again and the
crosshair disappears

Design Components listed 
in Component Highlight 
box

Add All Top or Bottom Components acts as a
wildcard selection of all Top or Bottom
components to the Selected Components box



  

Message Display &
Information Bar
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Message and Information Bar reports process status

Scrollable window reporting status of all processes including data load

Mode displays the function mode of the mouse.
Modes are set by View Menu or ToolBar selection
and stay in effect until specifically changed

Select  allows user to select items on 
the graphics screen

Zoom  allows user to draw zoom boxes 
to zoom-in on specific areas

Pan  allows user to pan across the design 
by dragging a  “from-to” line

Distance reports the XY distance between
two points as reported from the Measure
Routine.

XY location of mouse pointer

Display: Normal   -or-   Display: Flipped
Reports the current viewing side of the graphics

Normal is the typical mode in an as-designed view – usually
the Top side of the design

Flipped is looking from the opposite side – usually the Back 
side of the design



  

Item Selection
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Item Selection
• An important function to understand is the “Select Item” function

• Items on a layer (or multiple layers) can be selected for detailed item 
information 

• Net Tab and Component Tab automatically allow the selection of single Nets 
or Components.

• To select a specific item, be sure the Selection Tab is forward and you are 
in the “Select” mode by choosing the “Select Item” icon in Adiva’s toolbar… 
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Item Selection
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Once in “select” mode, be sure a layer(s) is ON

Then, with the left mouse button, click on any object on that
particular layer.  It will highlight in white.  On the left side of
the Adiva screen in the Selection Tab, attributes of the 
selected item will be reported.

To select more than one item, hold down the <shift>key while 
selecting.  Items will be added to a “select” list – a collection
of selected items.

Another way to select a group of items is to hold down the left
mouse key and drag a box over a group of items to be selected.
Everything inside or touching the drawn box will be highlighted 
in white meaning they are selected.

Another way to select a group of items is to hold down the right
mouse key and drag a box (typically a small box) outside of a group
of items.  Everything outside the drawn box will be highlighted in
white meaning they are selected.

Choose the “Select” button again in the toolbar, and everything
selected will become un-selected (white highlight goes away).



  

END
AdivaView Graphical User 

Interface
(User Guide)
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