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Representations in this User Guide are meant as an overview and quick reference.  Full details 
can be found in the On-Line manuals located at the ADIVA Corporation website - www.adiva.com

All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, 
or transmitted, in any form or by any means - electronic, mechanical, photocopying, recording, 

or otherwise - without the prior written permission of ADIVA Corporation.

ADIVA Corporation provides this User Guide "as is", without warranty of any kind, either expressed 
or implied, including, but not limited to, the implied warranties of merchantability and fitness for a 

particular purpose. ADIVA Corporation may make improvements and/or changes in the product (s) 
and/or the program (s) described in this manual at any time and without notice. 

Although ADIVA Corporation has gone to great effort to verify the integrity of the information herein, 
this publication could contain technical inaccuracies or typographical errors. Changes are periodically 
made to the information herein. These changes will be incorporated in new editions of this publication.

Notice
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Getting Started…
• Change PADS database units to either MILS or MM. 

• Define Gerber filenames and offsets - place design origin OUTSIDE of all artwork graphics - set artwork 
"Justification" to "Offset" - enter offset value in MILS or MM (see next slide for greater detail) 

• Save Gerber file definitions into PADS database and then output Gerber files. 

• Define and separate Drill files into individual files, plated holes, non-plated holes, buried-blind vias. 

• Define Drill filenames, set report file to be created in design units, set offsets to same as Gerber, save Drill file 
definitions into PADS database and then output Drill files. 

• Create PADS ascii (jobname.asc) database file in V5.0 format, containing All Data, using current design units set 
above (either MILS or MM not BASIC).

It is VERY important that the .asc file be created after the Gerber and Drill files have been created and their 
definitions saved in the PADS database in order for the .asc file to contain the filenames and formats created.  

ADIVA will be expecting to sync the filenames in the .asc file to match the actual Gerber and Drill filenames. 

NOTE:

• ALL data files (Gerber and Drill along with the .asc file) MUST be of the same units.  

• DO NOT modify any of the manufacturing filenames after they are created by PADS output or they will be out of 
sync with the .asc file which will impact the layer recognition and assignment function of the Pads to Adiva 
Interface. 
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CAM File Offset 
Important information regarding data file offsets for Gerber and Drill output

 Adjust the Justification setting in the Options tab for CAM layer setups.

 For a consistent offset for the ADIVA load, The justification option must be set to "offset"  
and the X Offset: and Y Offset: settings for each layer must match.

 Any other option (in justification) will result in the layers not being aligned when processed.

 Then when going thru the Adiva load, just use the negative equivalent to the PADS offset.
 
    if the offset in Pads (in mils) is X= 1000, Y= 3000
    then
    the offset in Pads to ADIVA Interface would be X= -1000, Y= -3000
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PADS > ADIVA    PROCESS
Basic Steps from Start to Finish

• Copy Gerber & Drill & .asc files into the same, clean directory
 

• Start Interface, choose .asc file from the above directory, setup data 
formats and define any offsets if required 
 

• Verify / Modify Layer Assignments 

• Verify Layer Description 

• Extract a Netlist from Manufacturing Data 

• Perform Netlist Compare using CAD Netlist against Mfg Netlist

• Define Pad and Hole Classes

• Run DRC Checks
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Step 1

PADS to ADIVA Interface
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If using the Adiva Navigator, select the Mentor Pads Import to start the data import
process...
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If not using the Adiva Navigator, select the Windows Desktop Shortcut to AdivaPads.

Either action will produce the Pads to Adiva Interface dialog on the next page…



  

Notice the data file offsets are valued in MILS
because the .asc file units value is set to Mils.
If the .asc file units are in MM, then these data
file offsets need to be in MM units.

Also the values are negative to move 
Gerber/Drill data back to the CAD 
system XY values

Set .asc file unitsChoose a .asc file from PADS Set Drill Data format fields.  In this case,
Absolute,2,4,Trail means….

Absolute coordinate reference
2 leading digits
4 trailing digits
Trailing zero suppression

When complete, Execute the conversion process

NOTE:  
These default values can be adjusted to reflect your
standard settings.  

Located in the %ADIVA_DATA% directory 
(default = c:\adiva\data) is a file named Pads.fmt.  
This file contains the settings that appear by default.  
Contact ADIVA support directly for file modification
details.
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Step 2

Layer Definition Confirmation 

and Adjust as Needed
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Adjust Layer Names as shown…

If it’s a positive layer internally – call it an Inner Circuit
If it’s a negative layer internally – call it a Plane

Uncheck any filename not desired
to be converted
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Make sure you check and adjust 
Drill Layer names (Plated / Non-Plated)

Select Continue to finish
conversion process
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Step 3

Data Conversion Complete
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  Database is built and ready for tweaking (if needed) when it says “Process Finished”
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Step 4

Verify Layer Description
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Verify Layer Description Definitions
as read and assembled from the .asc file

Choose Layer Description from Special menu

It is very important to verify “Type”, “Polarity”, “Z-Position”
(Z-Position value MUST be different for each electrical layer)

Select Update
when complete
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Step 5
Database Preparation - Editing

With a built database, there may be several other functions that need to be completed
to prepare a design for DRC analysis.  These functions may require some light editing of
the data.  They include….

Layer Alignment
Board Outline creation
Splitting Non-Plated Holes away from Plated Holes onto their own layer
Removing Title Blocks, Coupons, etc

If this is the case, reference the ADIVA EDITING QUICK-START GUIDE for details.

Then continue the process of prepping data for analysis….
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Step 6

Gerber Netlist Extraction
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Select Netlist Generator 
from the Toolkit menu

When netting of Gerber is complete, “Process Finished” will be displayed in message box
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Step 7

Netlist Compare
(See the Adiva Netlist Compare Guide

for further details of this process)
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Select the NetCmp tab

Browse and select the “net.crf” file for this job

Execute the Net Compare Routine

When Net Compare completes, a summary 
will appear describing any issues
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Step 1: Choose the Summary Item to review Step 2: Scroll to Review Problems and select one to see

Step 3: Select “Show Errors” 
to get idea where problem is

Turn on Layer(s)
Redraw or Zoom 
if Needed

Highlight toggles on or off the selected netname

Select a pin to bulls-eye its location
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Uncheck All Summary Items to “Exit” Net Compare
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Step 8

Pad / Hole Definition

Adds Pad “FUNCTION” Intelligence to 
Database
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Pad / Hole Definition needed to Identify Pad and Hole types
so that various checks can be run accurately

Select Analysis > Pad-Hole Definition to start routine
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Review the “stackups” that are created by zooming in on Layer 1
And selecting the “Seek” button for each Padstack Type.  Watch the screen jump
to the next “seek”

NOTE: Only 1 or 2 “seeks” per padstack type should be used to determine if the
default choice is correct.  

Do a quick glance at each one, adjust if needed (usually not needed) then move on 
to the next one – don’t let this process take more than a few minutes!

If default choice requires 
adjustment, adjust as needed
to one of the following options…

V = Via
S = SMT
P = Pin -Thru hole
C = Cosmetic (no real function)
t = test point
T = Non-Plated Hole
F = fiducial

Select Apply to finish routine
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Step 9

Load DRC Check Rules 
(See ADIVA DRC Check User Guide for more details)
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Select File > Import DRC Rules to bring in a master set of 
rules that you may have created.

Typically these are stored in the c:\adiva\data directory

In this case, load a file called “95_example.rul” which is
a basic set of IPC rules and industry standards that 
ADIVA supplies with all installations.
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Step 10

DRC Checks
(See ADIVA DRC Check User Guide for more details)
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Values are in inches or mm
5-mil space = 0.005 value

Check ON layers to review

Check ON checks to run

Execute to start checks
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Some checks don’t 
use mils for a value…

This is pixels

This is degrees
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Step 11

Violation Review
(See ADIVA DRC Check User Guide for more details)
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The Violation Checklist appears when checks are completed

   The Checklist can also be opened while checks are running by selecting its Toolbar Icon

Choose a Violation Type and amount to review 
by using ViolSeek on the main user interface

Violations are displayed by concern level 
as defined by the range setting Save violations to a file to read back and review later

Select Close Violation Checklist to close the dialog 
(violations are not lost) Copyright © 2021 – Adiva Corporation



  

Adjusting the Violation Range effects violation count distribution in the Violation Checklist.
The values listed for each range analyze how close a violation comes to the parameter to determine
the category a particular violation will be placed.  Changes take effect on Update. 

For example…. given the range values shown, if a check parameter is 0.005 and the violation 
amount is 0.00480 – this violation amount falls within ¼ Mil of the parameter categorizing the 
violation as “Tolerance”.  If the violation amount is 0.0046 – this makes the violation amount fall 
between ¼ and ½ mil of the parameter making it a “Concern” violation.
Anything else is deemed “Critical”.
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Creates a text summary report of all DRC violations. 
These violations are itemized by violation amounts 
and sorted by type.  Creation of the file can be either 
in ASCII “.txt” file format or in a comma-delimited 
spreadsheet-ready format.

Violations can be sorted by selecting the column button above each data column.
First selection sorts high to low, second sorts low to high, third sorts high to low again…

Empties all data contained in the 
“approved.vio” file.  All Accepted
violations are returned to the Violation
Checklist for review or deletion.

Check all boxes on for a violation type to Delete or Save from list
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This column shows the checking sequence
which is the order the checks were performed

Comments can be added to the checklist and saved to a Violation file.  Enter any text
and save the violation file – when the violation file is reloaded, these comments will 
display as they were entered
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Once a Violation Type is chosen for review,
select Viol Seek to review graphically the violations selected <shift>Viol Seek progresses backward

                                          NOTE:  Worst violations are always shown first

Violation details are shown here

It may be worthwhile to zoom-in to a violation 
as the seek function “seeks” at current zoom
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Individual or groups of violations can also be reviewed.  ViolSeek to the first violation type selected in 
the Violation Checklist,  choose the Select button then click on an individual violation or 
window-select a group of violations to review.  Notice the ViolSeen list shows the qty selected

Read information on the one violation selected – or - ViolSeek again to review 
the group items selected.  Choose Select again to un-select violations.

Copyright © 2021 – Adiva Corporation



  

A violation (or group of violations) can be Accepted which 
removes the violation(s) from the “violation seek” list.

The violation(s) is(are) not removed – just marked so that the 
violation(s) is(are) not seen.  Notice the violation count
shown in the Violation Checklist adjusts to a lower number
while the count for the Accepted violation(s) increases.

An “approved.vio” file is created in the DRC project directory
containing accepted violations.  This file can be used in 
future DRC analysis to filter already approved violations
from a new design.

A violation (or group of violations) can be Fixed which creates 
a file in the DRC project directory called “fix.vio”.  

This file is typically a collection of violations that 
a reviewer is interested in having someone else review 
or fix the violation in a CAD system.

The “fix.vio” file can be read into specific CAD systems or
read back into Adiva’s Violation Checklist to review only
the violations to be “fixed”.

A violation (or group of violations) can be Deleted removing 
it from the Violation Checklist results list.

Fixing or Accepting the Remaining
violations adds the currently viewed
violation and all those left to be seen 
into their appropriate .vio files
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Violations can also be saved in a format suitable for web-browser display

Select the DRC Archive Icon for web image creation

A DRC Archive dialog will appear…

Fill in items such as part number, revision,
designer’s and checker’s name if desired then…

Add any custom notes to help communicate the issue…

Select Create to finish the DRC Archive

Leave this dialog open and select Create for other
violations to be archived
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To view violations that have been archived to HTML, navigate through Windows Explorer finding the 
Adiva HTML directory (should be under the main job directory) and double-click on “index.htm”….
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A web browser should open displaying a matrix of violations that have been archived.

Violations should be clearly described – click on one to see a graphic of the violation
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Web browser should now show a graphic of the selected violation
including specific details about the violation…

Violation Description,
Check parameter,
Violation amount,
XY location,
Layer involved

Custom note 
added from main dialog

Same graphic displayed
in AdivaTools DRC Violation
review
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Extra DRC Outputs

Select File > Create DRC Rule Report to create an ASCII
text file documenting all of the DRC Check dialogs.
In this document will be a listing of all DRC Check
settings, their values and whether they are on/off.

This is useful in documenting the settings of all DRC
checks for later reference.

Select Toolkit > Design Summary Report to receive an 
ASCII text file in comma-delimited (spreadsheet ready) format 
summarizing details about the design.

Included in this report is enough 
information suitable for 
characterizing the design including 
items such as board dimensions, 
hole counts, min spacing 
values, etc…
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