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Representations in this User Guide are meant as an overview and quick reference.  Full details 
can be found in the On-Line manuals located at the ADIVA Corporation website - www.adiva.com

All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, 
or transmitted, in any form or by any means - electronic, mechanical, photocopying, recording, 

or otherwise - without the prior written permission of ADIVA Corporation.

ADIVA Corporation provides this User Guide "as is", without warranty of any kind, either expressed 
or implied, including, but not limited to, the implied warranties of merchantability and fitness for a 

particular purpose. ADIVA Corporation may make improvements and/or changes in the product (s) 
and/or the program (s) described in this manual at any time and without notice. 

Although ADIVA Corporation has gone to great effort to verify the integrity of the information herein, 
this publication could contain technical inaccuracies or typographical errors. Changes are periodically 
made to the information herein. These changes will be incorporated in new editions of this publication.

Notice

http://www.adiva.com/


  

ADIVA Graphical User Interface 
Highlights

• Graphical Interface is not locked while checks and other processes are running.  This allows a 
user to view graphics or review violations while other processes are running.

• Layer Display and Action Display are both dockable panels.  They can be moved to different 
locations to create a larger viewing area for a design.

• All data created automatically by Adiva is stored in the local directory for a particular job.

• Adiva can be launched and checks run in a black-box mode by using a macro to control all 
checking functions.
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Starting the Adiva Interface
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On the Windows Desktop, double-click the AdivaTools icon
On the command line, type   >AdivaTools <jobname>   (jobname is optional)

The graphical Interface will appear and if a jobname is supplied it will appear like below.  If a jobname is
not supplied, the Layer Listing on the right will be empty and the next step will be to access the File
menu to find and load a job.



  

Menus
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Across the top of the Adiva Graphical Interface are a series of menus.  

The File Menu performs the following….

Select and Load an existing database

Save the current database

Exit and close AdivaTools

Import a pre-defined set of DRC rules – automatically loads all DRC menus

Saves the rules defined in the DRC menus to a 
master file for later use

Prints out a listing of all DRC checks and their current parameters

Starts the Gerber and Drill data import process
See the Adiva Gerber In Quick-Start Guide for details

Converts an IPC-D-356 netlist file into a file ready 
for Adiva Netlist Compare
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The Edit Menu allows these functions.
See the Adiva Editing User Guide for more details.

Selected item(s) are deleted from the Adiva database

Selected item(s) are copied to another layer

Selected item(s) are moved to another layer

Used to change the aperture size of a selected pad or segment

Any layer that has its “Edit” box on will be deleted from 
the Adiva database

A specific XY value can be entered to move a layer from one location to another

By selecting two points ( “from” point then “to” point ), two or more layers can be aligned
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The View Menu controls various graphical related functions.
Take close note of the keyboard shortcuts that are also available for each function

Keyboard Shortcuts

These functions control display of toolbars and activity displays

Produces a file that can be used by certain CAD systems to
center their screen to the Adiva screen

See the Item Select Function described later in this User Guide
Essentially this function allows a user to select or un–select
an item(s) on the screen

Center and fit all graphics on the screen

Refreshes the current graphics screen

Controls the display of a violation after a DRC check has been run
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The View Menu controls various graphical related functions.
Take close note of the keyboard shortcuts that are also available for each function

Keyboard Shortcuts

Zoom Functions:

   Zoom allows a user to draw an area to zoom
   click left-mouse down-drag-let go - defined area zooms in

   Zoom-In allows a user to zoom in 1 level on the current screen
       Mouse Scroll-Up performs the same function

   Zoom-Out allows the user to zoom out 1 level on the current screen
       Mouse Scroll-Down performs the same function

   Center Zoom-In allows the user to zoom in 1 level centering on the
   mouse location

   Center Zoom-Max allows the user to zoom in 8 levels centering on
   the mouse location

Back returns the user to the previous displayed screen
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The View Menu controls various graphical related functions.
Take close note of the keyboard shortcuts that are also available for each function

Keyboard Shortcuts

Pan Functions:

   Pan allows a user to click left-mouse down on a location and drag 
   a line to a new location (let go) then redraws the screen with the 
   original location now in the new location.  

      In short: drag this point from here to here

      Mouse scroll click-down-drag-release performs same function 
      without placing user in “Pan-State”

   Pan Up moves the current window-of-view 90% up

   Pan Down moves the current window-of-view 90% down

   Pan Left moves the current window-of-view 90% to the left

   Pan Right moves the current window-of-view 90% to the right

Back returns the user to the previous displayed screen
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The Special Menu performs the following….

Measure provides a tool allowing the user to drag a line
anywhere on the screen and a total distance from start
to end is displayed in the status bar at the bottom of the
Adiva Graphical Interface.

Select Measure > Left-Mouse down-drag-let go
on the graphics screen

“Snap” option on the Selection Tab is helpful with 
this function

Layer Description provides access to layer stackup information.
See the Adiva Gerber Input Quick Start Guide for further details.
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The Analysis Menu performs the following….

Pad-Hole Definition is a process to assign
functionality to padstacks.  See the Adiva
Gerber In Quick Start Guide for further details.

These seven DRC dialogs allow access to
setting and executing parameters defined
for DRC checks.  See the Adiva DRC Check
User Guide for further details.

Group Execute provides the capability to
launch several DRC check dialogs in one
selection. See the Adiva DRC Check
User Guide for further details.

Violation Checklist opens the results list of DRC
checks that have been performed.

Violation Checklist can be opened at any time during 
the checking process – even while checks are 
running – to review violations collected.

See the Adiva DRC Check User Guide for further details.

Areas can be created that either Include
or Exclude certain areas for checking.
See the Adiva DRC Check User Guide 
for further details.
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The Toolkit Menu performs the following….

Starts and performs the Netlist Extraction
process.  This process looks at all Gerber
and Drill data and determines data
interconnectivity as implied by that data.

End result is a database that understands
what items are interconnected to other items
in the design.  If the artwork as it stands is
used to fabricate a circuit board – this netlist
will reflect that interconnectivity of copper.

This function is used during the database 
build process. See the Adiva Gerber In 
Quick Start Guide for further details.

Archive generates a series of web based
images that communicate DRC check
violations.
 
See the DRC Check User Guide for further 
details.

Design Summary Report creates a text file 
suitable for input into a spreadsheet. This file 
contains summary information about the design 
such as pad sizes, trace sizes, hole sizes, 
quantities, etc…

Netlist Report File generates a simple text file
summarizing netlist connectivity for this data 
set.  Location, side and net information are 
major components of this netlist.



  

ToolBar
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The ToolBar provides easy access to many functions
that are duplicated by a menu selection or keyboard shortcut

File Open – select and load an existing database

File Save – saves an existing database

Select Item – allows user to select or un-select items on the screen
   See the Item Select Function described at the end of this User Guide.

Find Function brings the Find Tab forward in
the action tabs to allow searching for items,
XY locations, nets and components… Measure provides a tool allowing the user to drag a line

anywhere on the screen and a total distance from start
to end is displayed in the status bar at the bottom of the
Adiva Graphical Interface.

Select Measure > Left-Mouse down-drag-let go
on the graphics screen

“Snap” option on the Selection Tab is helpful with 
this function
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The ToolBar provides easy access to many functions
that are duplicated by a menu selection or keyboard shortcut

Cad Netlist Compare Icon brings forward
the NetCmp tab in the action tabs panel

DRC Include / Exclude areas can be created
by selecting this icon.  Further details of this function
can be found in the Adiva DRC Checks User Guide

Violation Checklist opens/closes the results list of DRC
Checks that have been performed.

Checklist can be opened at any time during the checking 
process – even while checks are running – to review 
violations collected.

See the Adiva DRC Check User Guide for further details.

CadLink produces a file that can be 
used by certain CAD systems to
center their screen to the Adiva screen
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The ToolBar provides easy access to many functions
that are duplicated by a menu selection or keyboard shortcut

Archive generates a series of web based
images that communicate DRC check
violations.
 
See the Adiva DRC Check User Guide for further 
details.

Refreshes the current graphics screen

Closes and opens the Action Tab on the left side of
Adiva’s Graphical Interface.  Closing this tab allows
greater viewing area for a design.

Closes and opens the Layer Display Tab on the right side of
Adiva’s Graphical Interface.  Closing this tab allows
greater viewing area for a design.
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The ToolBar provides easy access to many functions
that are duplicated by a menu selection or keyboard shortcut

Refreshes the current graphics screen

Center and Fit all graphics on the screen

Zoom allows a user to draw an area to zoom
   click left-mouse down-drag-let go -- defined area zooms in

Zoom-In allows a user to zoom in 1 level on the current screen
Mouse Scroll-Up performs the same function

Zoom-Out allows the user to zoom out 1 level on the current screen
Mouse Scroll-Down performs the same function

Back returns the user to the previous displayed screen
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The ToolBar provides easy access to many functions
that are duplicated by a menu selection or keyboard shortcut

Refreshes the current graphics screen

Pan allows a user to click left-mouse down on a location and drag a line to a new location 
(let go) then redraws the screen with the original location now in the new location.  Mouse 
scroll click-down-drag-release performs same function without placing user in “Pan-State”.

In short: drag this point from “here” to “there”

Pan Up moves the current window-of-view 90% up

Pan Down moves the current window-of-view 90% down

Pan Left moves the current window-of-view 90% to the left

Pan Right moves the current window-of-view 90% to the right



  

Layer Display
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Layer Display List controls access to visual and physical selections
of each graphical layer of a design

This is the “Show” column.  Check this box
to “Show” all layers on the screen.  Uncheck
this box to turn off display for all layers.
(Screen refresh may be required to see
selected layers)

This is the “Edit” column.  Check this box
to be able to select items on all layers.
Uncheck this box to disable selection for
all layers.  These layers become “active”
layers.

Check individual boxes to show individual layers
(Screen refresh may be required to see
selected layers)

By checking the Edit box, items can be selected
on these layers.  These layers become “active” layers

Checking a box in the 3rd column shows that layer
on top of all other layers set to display
(only one layer at a time can be on TOP)
(screen refresh is automatic)
(TIP!  It is sometimes handy to use this to redraw
the screen when layer selections are changed)

Checking a box in the 4th column inverts the
graphical image – useful in showing negative
layers in their “real” view
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Layer Display List controls access to visual and physical selections
of each graphical layer of a design

Click on the color box to change a layer color

Select a new color and choose OK to update
layer color (screen refresh may be required)



  

Action Display Tabs

Copyright © 2021 – Adiva Corporation



  
Copyright © 2021 – Adiva Corporation

Selection Tab controls the function and reports the results of a “select” action

Selected Item information:

   Type of item selected - flashed pad, segment, polygon, arc
   Quantity of items selected
   Net name from CAD system if Net Compare is run
      number in parenthesis is Adiva net number
   Reference Designator & Pin Number if Net Compare is run
   Aperture size of object selected and its rotation
   Class of a pad/hole item
      -  = pad/hole class not available
      S = Surface Mount
      P = pin-thru hole
      V = via
      T = tooling hole
      t = test point
      F = fiducial
      C = cosmetic (no real function)
   Layer item is located on
   Separation spacing between any two items selected
   XY coordinates of a selected item

See the Item Selection slides at the end of this guide for 
“How to Select” information….
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Selection Tab controls the function and reports the results of a “select” action

Select Item Control - This area functions like a filter to control 
what the select function is allowed to pick up
Check a box off to make certain types of objects non-selectable

Specific aperture sizes can be selected by highlighting that
aperture in blue.  By default, all apertures are selectable.

Specific Pad/Hole classes can be selected by highlighting
that Pad/Hole class in blue.  By default, all Pad/Hole classes
are selectable.

An example highlight function would be…  check on only the 
“Pads” box (Lines, Arcs, Polygons off) and select pad class “F”
then window-select the design layer 1 – all of the class “F” pads
(fiducials) on layer 1 should highlight

Snap option controls the select and measure routines…
snap to pad, snap to line, snap to item, etc…

Separation option controls the report of two items selected…
Edge - reports the spacing edge-to-edge between two selected items
Center - reports the spacing center-to-center between two selected items

See the Item Selection slides at the end of this guide for 
“How to Select” information….
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Violation Tab controls the ability to view a DRC violation
(Further details are available in the Adiva DRC Check User Guide)

When the Violation Checklist is opened, the Violation Tab is automatically brought forward for access

Viol Seek advances the viewing of a violation
type selected in the Violation Checklist

<shift>Viol Seek moves backward through the
selected violation list.

Information about the currently displayed
violation

Violation display progress
Current violation / total violations

Actions for a particular displayed violation…
   Accept it so its not seen in subsequent reviews
   Fix it so that a file of chosen violations is set aside
      for further review
      (TIP!  Use this file to send a group of violations
      to the CAD system)



  
Copyright © 2021 – Adiva Corporation

NetCmp Tab controls the Netlist Compare process
(Further details are available in the Adiva Net Compare User Guide)

The name of a converted netlist prepared for Adiva Net Compare
is entered then Execute is selected to perform the function.

Adiva requires netlists formatted into a particular format.  Several
filters have been developed to perform that format conversion.
In most CAD interfaces, this is done for the user directly from the
CAD system.  Outside of a direct CAD Interface, an IPC-D-356
file is used but must still be converted.  See the File > Convert IPC
menu selection for details on how to convert an IPC netlist.

After the Netlist Compare process takes place, a summary is
provided in this area.  A file can be created containing this
same summary data by entering a filename and selecting
the Save button.

Select one of the summary items by checking the box and details
about the issue will appear in the lower two boxes.  Uncheck the
box to remove the details.

See the Adiva Net Compare User Guide for further details in how to 
operate these functions.
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Find Tab provides search functions

Type in an XY location either in inches or mm,
select Search and a crosshair will appear at 
the requested location of the design.
  
Selecting Clear removes the crosshair from display.

Type in a netname or select a netname from the list
below, select Search and the selected netname will
highlight in white as it appears in the design.

Selecting Clear removes the highlighted net from display.

Type in a RefDes or select a RefDes from the list
below, select Search and a crosshair will appear
on the selected Refdes.

Selecting Clear removes the crosshair from display.

Type in an Adiva Net Number, select Search and the 
selected net number will highlight in white as it appears
in the design.

Selecting Clear removes the highlighted net from display.



  

Message Display &
Information Bar
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Message and Information Bar reports process status

Scrollable window reporting status of all processes including DRC Checks
The term “Process Finished” is a common term displaying the end of a requested function

Mode displays the function mode of the mouse.
Modes are set by View Menu or ToolBar selection
and stay in effect until specifically changed

Select > allows user to select items on 
the graphics screen

Zoom > allows user to draw zoom boxes 
to zoom-in on specific areas

Pan > allows user to pan across the design 
by dragging a  “from-to” line

Status will show as “Busy” if certain functions
such as DRC Checks are running.  This doesn’t
mean the software is inaccessible, graphics can still
be reviewed, violations can still be reviewed, etc…

Distance reports the XY distance between
two points as reported from the Measure
Routine.

XY location of mouse pointer



  

Item Selection
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Item Selection
• An important function to understand is the “Select Item” function

• Items on a layer (or multiple layers) can be selected for detailed item 
information or for editing 

• Violations can be selected for individual or group review

• Control of selected items is handled by the Selection Tab.  
See slide 2 of the Action Display Tab section in this guide for further details.

• To select an item, be sure you are in the “Select” mode.  This is done by 
choosing the “Select Item” icon in Adiva’s toolbar… 

Copyright © 2021 – Adiva Corporation

To Un-select an item, again choose the “Select Item” icon



  

Item Selection
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Once in “select” mode, be sure a layer(s) is ON for Edit

Then, with the left mouse button, click on any object on that
particular layer.  It will highlight in white.  On the left side of
the Adiva screen in the Selection Tab, attributes of the 
selected item will be reported.

The item can also be modified by any editing function available.
See the Adiva Editing User Guide for details

To select more than one item, hold down the <shift>key while 
selecting.  Items will be added to a “select” list – a collection
of selected items.

Another way to select a group of items is to hold down the left
mouse key and drag a box over a group of items to be selected.
Everything inside or touching the drawn box will be highlighted 
in white meaning they are selected.

Another way to select a group of items is to hold down the right
mouse key and drag a box (typically a small box) outside of a group
of items.  Everything outside the drawn box will be highlighted in
white meaning they are selected.

Choose the “Select” button again in the toolbar, and everything
selected will become un-selected (white highlight goes away).
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